Delayed balance updates in Indonesia

Incident Report for Luno

Resolved

Balance updates are now processing normally. Our systems are fully operational.
Posted Oct 03, 2025 - 11:22 UTC

Monitoring

A fix has been implemented, and balance updates are now functioning normally. We are continuing to monitor the system to ensure stability.
Posted Oct 03, 2025 - 10:57 UTC

Identified

We have identified an issue that causes users to experience delays in viewing updated balances. Our team is aware of the issue and working to restore normal update times as quickly as possible.
Posted Oct 03, 2025 - 10:15 UTC