Bank transfer with Flutterwave disrupted
Incident Report for Luno
Resolved
This issue has been resolved.
Posted May 14, 2022 - 09:44 UTC
Identified
We are currently experiencing an issue with bank transfers via Flutterwave.

This service is currently delayed, all transactions using this means should be automatically reversed.

All other deposit methods are working as expected.

We are looking into this as a matter of priority.

We apologise for any inconvenience.
Posted May 14, 2022 - 09:09 UTC