Interrupted Bank Deposits in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Jun 17, 2021 - 06:35 UTC
Identified
Our service provider will be undergoing maintenance on Thursday, 17th June 2021 at 2:30AM - 3:30AM WIB time. Please avoid making deposits during this downtime.
Posted Jun 14, 2021 - 06:40 UTC