Deposits creation issue in Nigeria
Incident Report for Luno
Resolved
The issue affecting delayed deposit vouchers in Nigeria has been resolved.

Thank you for your patience.
Posted Jun 24, 2022 - 16:58 UTC
Investigating
We are currently investigating an issue that is preventing our customers in Nigeria from creating successful deposits. We apologize for any inconvenience caused.
Posted Jun 24, 2022 - 13:55 UTC