Delayed deposits and withdrawals in Nigeria
Incident Report for Luno
Resolved
We can confirm that deposits and withdrawals are both processing normally. Thank you for your patience.
Posted Sep 18, 2022 - 12:36 UTC
Investigating
We are currently experiencing an issue that may be causing temporary delays with Nigerian bank deposits and withdrawals.
Posted Sep 18, 2022 - 09:56 UTC