Slow BTC send transactions
Incident Report for Luno
Resolved
All send transactions have returned to normal.

We appreciate your patience.
Posted Feb 03, 2023 - 12:03 UTC
Monitoring
The backlog has started to come down. While the backlog is still being processed, sends will still be slower than usual. We're continuing to monitor congestion closely and we will provide further updates as soon as we notice substantial improvement.
Posted Feb 03, 2023 - 11:23 UTC
Identified
We've identified a backlog of BTC send transactions and we're investigating the cause. Sends may take longer than normal to process.
Posted Feb 03, 2023 - 09:37 UTC