Deposits and withdrawals service interruption in Singapore
Incident Report for Luno
Resolved
Deposits and withdrawals are now being processed as scheduled. Thank you
Posted May 23, 2022 - 03:22 UTC
Identified
Our bank partner will be undergoing service maintenance on 22nd May 2022 between 01:30 AM - 05:00 AM which may affect your deposits and withdrawals via bank transfer. During this downtime, please use StraitsX as an alternative if you encounter any issues. All services will resume to normal after the maintenance is complete. Thank you for your understanding.
Posted May 19, 2022 - 03:12 UTC