SMS delivery marked as spam in Singapore
Incident Report for Luno
Resolved
The issue has been resolved. Thank you for your patience.
Posted Feb 10, 2023 - 09:10 UTC
Identified
Please be advised that you might be receiving Luno SMSes labeled as "Likely-SCAM", with IMDA's Singapore SMS Sender ID Registry (SSIR) regime kicked off starting 31 Jan.

We apologise for any inconvenience caused, and we are working on resolving this as soon as possible.
Thanks for your understanding.
Posted Feb 02, 2023 - 07:01 UTC