Deposit and withdrawal service interruption in Singapore
Incident Report for Luno
Resolved
Maintenance has completed successfully, bank deposits and withdrawals are functioning as normal.

Thanks for your patience.
Posted Nov 13, 2022 - 14:44 UTC
Identified
Our banking partner will be undergoing a service maintenance which may affect your deposits and withdrawals via bank transfer.

Affected times:
Sunday, 13 November 2022 02:00 AM - 06:00 AM

During this downtime, please use StraitsX as an alternative if you encounter any issues.

All services will resume to normal after the maintenance is complete. Thank you for your understanding.
Posted Nov 11, 2022 - 06:24 UTC