Delayed BTC receives
Incident Report for Luno
Resolved
This has been resolved and all BTC receives are being processed as normal.
Posted Nov 01, 2022 - 15:19 UTC
Investigating
We are currently investigating an issue causing delayed BTC receives.

We are working on this as a priority.
Posted Nov 01, 2022 - 14:38 UTC