Delayed account verification in Malaysia
Incident Report for Luno
Resolved
We have resumed processing all new verification requests without delays. Thank you for being patient.
Posted May 18, 2022 - 07:28 UTC
Identified
We are currently experiencing delays with account verification for customers in Malaysia. This is mostly due to our partner bank used for customer verification being closed on the 16th of May for a public holiday.
Posted May 16, 2022 - 16:02 UTC