Bank transfer with Flutterwave disrupted in South Africa
Incident Report for Luno
Resolved
We can confirm that card deposits are being processed successfully. Thank you for being patient.
Posted Jun 30, 2022 - 08:13 UTC
Investigating
We are currently experiencing an issue with card payments via Flutterwave.

This service is currently unavailable. All other deposit methods are working as expected.
Posted Jun 30, 2022 - 02:35 UTC