Delayed crypto and fiat withdrawals.
Incident Report for Luno
Resolved
The issue has been resolved and all delayed send transactions are being processed. We apologize for any inconvenience this may have caused.
Posted Nov 09, 2022 - 21:07 UTC
Monitoring
We are starting to see crypto and fiat withdrawals being processed successfully. We will continue to monitor the transactions.
Posted Nov 09, 2022 - 20:45 UTC
Identified
We have identified the issue and a fix is being implemented.
Posted Nov 09, 2022 - 20:31 UTC
Investigating
We are currently investigating an issue with delayed crypto sends and fiat withdrawals.

Our team is investigating this as a priority. Updates to follow.
Posted Nov 09, 2022 - 20:28 UTC