Blog posts unavailable
Incident Report for Luno
Resolved
The issue experienced with discover.luno.com has been resolved.
All blog posts are now accessible and can be viewed
Posted Jan 26, 2023 - 02:09 UTC
Investigating
We are currently investigating an issue that is impacting discover.luno.com, which is currently unavailable.
This is causing an error when trying to view any of our blog posts.

We are looking into this as a matter of priority.
Posted Jan 26, 2023 - 01:45 UTC