Slow Bitcoin sends
Incident Report for Luno
Resolved
Bitcoin sends have returned to normal, thanks for your patience.
Posted Sep 08, 2020 - 08:41 UTC
Identified
We've identified an issue affecting Bitcoin sends from Luno wallets, Bitcoin sends may be slower than usual.
Updates to follow.
Posted Sep 08, 2020 - 07:52 UTC