Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Oct 25, 2022 - 01:23 UTC
Identified
Withdrawals in Malaysia will not be processed on 24th October 2022 due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Withdrawals requested during this time will be processed on 25th October 2022.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Oct 21, 2022 - 06:29 UTC