Deposits and withdrawals service interruption in Australia
Incident Report for Luno
Resolved
Deposits and withdrawals are now being processed as scheduled.

Thank you for your patience.
Posted Jun 29, 2022 - 02:19 UTC
Identified
Our payments provider will be undergoing a service maintenance on 29th June 2022 between 01:00 AM - 01:45 AM AEST which may affect your deposits and withdrawals.

Appreciate if you could plan and make deposits before/after the following times:
29th June 2022 01:00 AM - 01:45 AM AEST

All services will resume to normal after the maintenance is complete.

Thank you for your understanding.
Posted Jun 28, 2022 - 06:26 UTC