Delayed deposits in Nigeria
Incident Report for Luno
Resolved
The issue has been resolved and deposits are functioning as normal.

We thank you for your patience.
Posted Jan 09, 2022 - 13:13 UTC
Identified
We have identified an error when trying to deposit in Nigeria. We are working with our third-party providers to resolve this as soon as possible.

We will update once the solution has been implemented and apologize for the degraded user experience.
Posted Jan 09, 2022 - 08:42 UTC