No further impact since our last update, thanks again for your patience.
Posted Nov 25, 2024 - 09:20 UTC
Monitoring
Seeing a much better experience across Luno, we'll continue to monitor.
Posted Nov 24, 2024 - 13:48 UTC
Identified
While we are seeing increased levels in traffic and some responses may be slightly slower we aren't seeing any errors, we're working to normalise these response times.
Posted Nov 24, 2024 - 13:22 UTC
Investigating
We're investigating reports of degraded performance across all Luno services, updates to follow.