Delayed deposits in Nigeria
Incident Report for Luno
Resolved
All deposits are currently being processed without any issues.

We apologise for any inconvenience caused and appreciate your patience.
Posted Jul 19, 2024 - 10:42 UTC
Monitoring
Deposits are being processed as normal, our team will continue to monitor them closely.
Posted Jul 19, 2024 - 10:02 UTC
Identified
We are aware that some customers are experiencing intermittent delays with deposits affecting both vouchers and bank transfers due to downtime from one of our third-party providers.

We are working closely with them to get this resolved.

We apologise for any inconvenience caused and appreciate your patience.
Posted Jul 19, 2024 - 09:15 UTC