Delayed withdrawals in Kenya

Incident Report for Luno

Resolved

We can see that there are no further issues with withdrawals and it should be working as expected.

We appreciate your understanding and patience.

Thank you.
Posted May 03, 2025 - 10:58 UTC

Identified

We have identified an issue that's causing customers to get an error when attempting to withdraw funds.

Unfortunately, this issue is with our payment provider, we are working closely with them to resolve this as soon as possible.

We appreciate your understanding and apologise for any inconvenience this may cause.
Posted May 03, 2025 - 10:00 UTC