Delayed withdrawals in South Africa
Incident Report for
Luno
Resolved
We do not see any further delays with withdrawals.
We appreciate your understanding in this matter.
Posted
Feb
18
,
2025
-
09:38
UTC
Update
Update:
Some customers may still experience longer than normal processing times.
We are still working with our 3rd party banking partner to resolve this issue as soon as possible.
Posted
Feb
14
,
2025
-
08:24
UTC
Identified
We have identified an issue that may cause longer than normal processing time for both express and normal withdrawals for customers.
We are currently working with our 3rd party banking partner to resolve this issue.
We apologise for any inconvenience caused.
We will update you as soon as we have further information.
Posted
Feb
13
,
2025
-
13:55
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed withdrawals in South Africa
via . You'll receive .