Delayed Customer Withdrawals In South Africa

Incident Report for Luno

Resolved

Issue has been resolved, ZAR withdrawals are now processing.
Posted Nov 12, 2025 - 14:00 UTC

Monitoring

Withdrawals are now processing. We will monitor for any additional issues.

Thank you for your patience.
Posted Nov 12, 2025 - 06:09 UTC

Identified

We have identified an issue were there are delays with withdrawals. Customers in South Africa requesting ZAR withdrawals are seeing slower than normal withdrawal times.

We are working on the issue as a priority and we apologise for any inconvenienced caused.
Posted Nov 11, 2025 - 11:19 UTC