Maintenance on discover.luno.com

Incident Report for Luno

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 13:31 UTC

Investigating

discover.luno.com will undergo a scheduled maintenance on Monday, March 31st at 12:00 - 13:00 UTC.

During this time, you may experience brief service interruptions or downtime. Our team will work to minimise disruptions and complete the maintenance as quickly as possible.

We appreciate your patience as we work to enhance your experience. For updates during the maintenance or to report any issues afterward, please contact our support team.

Thank you for your understanding.
Posted Mar 31, 2025 - 07:07 UTC