Slow Bank Deposits in Malaysia
Incident Report for Luno
Resolved
This issue has been resolved by AmBank.

Thank you.
Posted Sep 30, 2020 - 13:44 UTC
Identified
We have been informed by AmBank that there is a technical issue on their RPP platform. This is affecting all payments via Instant Transfer to AmBank accounts.

AmBank hopes to have this resolved soon. In the meantime, please make use of IBG deposits to your Luno wallet.
Posted Sep 30, 2020 - 07:50 UTC