Withdrawal and deposit delays for Europe
Incident Report for Luno
Resolved
This incident has been resolved by our third-party provider. We are seeing no further issues with delays in withdrawals and deposits.

Thank you for your patience in this regard.
Posted Aug 31, 2023 - 11:54 UTC
Identified
Some customers in Europe may be experiencing delays in withdrawals and deposits due to intermittent downtime with one of our third-party providers.

We are monitoring the situation closely and will provide updates as they become available.
Posted Aug 30, 2023 - 07:47 UTC