Delayed withdrawals in Kenya

Incident Report for Luno

Resolved

Update:

Customer should see no further delays with their withdrawals.

All withdrawal processing times should be as normal.

We appreciate your understanding in this matter.
Posted Aug 05, 2025 - 09:33 UTC

Identified

We have identified an issue that's causing customers to experience longer-than-normal withdrawal processing times when attempting to withdraw funds.

We are working with our payment provider to solve this issue.

We will provide updates as soon as we can.
Posted Aug 04, 2025 - 11:16 UTC