Instant transfer deposits have been performing as usual since 09:55 UTC today. Thanks for your patience, this is now fully resolved.
Posted Sep 26, 2023 - 12:41 UTC
Monitoring
Capitec have confirmed that they're seeing normal results, we're continuing to monitor. Instant transfer deposits for Capitec should be performing as usual.
Posted Sep 26, 2023 - 09:55 UTC
Identified
Instant transfer deposits made by customers banking with Capitec may take longer than usual to relfect in your ZAR wallet. You may make use of a normal EFT deposit, however these too would be delayed as banks take longer to clear these over weekends and public holidays.
Unfortunately this issue seems to be with Capitec and something that is out of our control. We don't have an ETA to share just yet, the minute that changes we'll update this status page.