We are no longer experiencing SMS delivery delays when sending messages. This has been fully resolved.
Posted Mar 18, 2025 - 11:57 UTC
Monitoring
We are observing a recovery in SMS delivery delays. Messages are now being sent with improved delivery times. Our team will continue to monitor for any further issues and provide updates as necessary.
Posted Mar 18, 2025 - 09:59 UTC
Identified
We have identified delays in SMS delivery in Nigeria, which may affect the delivery of OTP messages sent to some customers during the onboarding process. Our team is actively working to resolve this issue.