Delayed Withdrawals In Nigeria
Incident Report for Luno
Resolved
The issue has been resolved, and everything is now functioning normally.

Thank you for your understanding and patience.
Posted Sep 15, 2024 - 10:13 UTC
Identified
We are currently experiencing an issue that may be causing delays with withdrawals for both bank transfers and voucher withdrawals.

Deposits remain unaffected.

Updates to follow.
Posted Sep 15, 2024 - 05:21 UTC