Intermittent Deposit errors in Nigeria
Incident Report for
Luno
Resolved
Update:
We are no longer seeing errors when Nigerian customers attempt to deposit.
We appreciate your patience and understanding in this matter.
Posted
Oct
20
,
2025
-
11:03
UTC
Identified
We have identified an issue affecting deposits in Nigeria.
Nigerian customers who attempt to deposit into their Luno account may experience an error.
Unfortunately, this issue is on our payment providers' side; we are working with them to try to solve this as quickly as possible.
Updates to follow.
Posted
Oct
20
,
2025
-
08:43
UTC
×
Subscribe to Incident
Subscribe to updates for
Intermittent Deposit errors in Nigeria
via . You'll receive .