Slow Bank Deposits in Malaysia
Incident Report for Luno
Resolved
Deposits are now being allocated as scheduled. Thank you
Posted Mar 24, 2021 - 03:51 UTC
Investigating
We're aware of a delay with Malaysia deposits via bank transfer (GIRO and Instant Transfer) and our team is currently investigating it. We hope to have this resolved soon. In the meantime, please make use of FPX deposit method in your Luno wallet.
Posted Mar 20, 2021 - 14:35 UTC