Delayed account verifications in South Africa
Incident Report for Luno
Resolved
This has been resolved and account verifications are being processed as normal.
Posted Oct 09, 2024 - 09:56 UTC
Identified
We have identified an issue with one of our third-party providers that may be causing account verifications in South Africa to be delayed.

We are working closely with them to get this resolved.
Posted Oct 08, 2024 - 09:49 UTC