Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Sep 01, 2022 - 01:45 UTC
Identified
Withdrawals in Malaysia will not be processed on 31st August 2022 due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Withdrawals requested during this time will be processed on 1st September 2022.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Aug 30, 2022 - 07:11 UTC