Delayed withdrawals in Australia
Incident Report for
Luno
Resolved
Processing times have returned to normal when withdrawing AUD.
We appreciate your understanding and apologise for any inconvenience this may cause.
Posted
Sep
29
,
2024
-
09:24
UTC
Identified
Customers may see slower than normal processing times when withdrawing AUD.
We appreciate your understanding and apologise for any inconvenience this may cause.
Posted
Sep
28
,
2024
-
15:43
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed withdrawals in Australia
via . You'll receive .