Delayed Crypto Sends in Malaysia
Incident Report for
Luno
Resolved
This has been resolved and crypto sends are working as expected.
Posted
Feb
06
,
2024
-
00:02
UTC
Investigating
We are currently experiencing an issue causing delayed crypto sends for customers in Malaysia due to third-party downtime.
We are working to resolve this as a priority and will provide further updates as they become available.
Posted
Feb
05
,
2024
-
23:03
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Crypto Sends in Malaysia
via . You'll receive .