Delayed Deposits in Nigeria

Incident Report for Luno

Resolved

The issue has been resolved and we thank you for your patience
Posted Jul 22, 2025 - 14:45 UTC

Investigating

We are currently experiencing an issue with deposits for customers in Nigeria that is causing deposits to be delayed. Our team is currently investigating the issue and are working on resolving this as soon as possible. We apologise for inconvenienced caused and we thank you for your patience.
Posted Jul 22, 2025 - 10:35 UTC