No further issues since our last update, thanks for patience.
Posted Aug 22, 2024 - 19:11 UTC
Monitoring
Instant Buy via Card is performing as normal, we're monitoring closely.
Posted Aug 22, 2024 - 18:41 UTC
Identified
Customers in South Africa are unable to use cards to Instant Buy crypto. Other deposit methods remains available. Apologies for any inconvenience caused.