Delayed bank deposits and withdrawals in Europe

Incident Report for Luno

Resolved

All bank transfer deposits and withdrawals are working normally. Thank you for your patience.
Posted Nov 08, 2022 - 15:48 UTC

Identified

Some customers may experience slower than normal bank transfer deposits and withdrawals. We’re working with the bank to see this resolved as soon as possible.

Thank you for your patience.
Posted Nov 04, 2022 - 16:08 UTC