Delayed bank withdrawal in Malaysia
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled. Thank you
Posted Jul 21, 2021 - 04:54 UTC
Identified
Withdrawals in Malaysia will not be processed on 20th July 2021 due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 21st July 2021.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jul 19, 2021 - 04:14 UTC