All withdrawals are being processed as normal. Thanks for your patience.
Posted Sep 21, 2023 - 09:40 UTC
Monitoring
The backlog of withdrawals have been processed, we're monitoring closely for any further delays.
Posted Sep 21, 2023 - 09:13 UTC
Identified
The issue has been identified and we're working on a fix to process withdrawals.
Posted Sep 21, 2023 - 08:55 UTC
Investigating
We're investigating an issue affecting fiat withdrawals in all regions. If you requested a withdrawal in the last 12 hours it will take longer than normal to process.