Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawal status in customer wallets have been updated and now being processed as scheduled.

Thank you
Posted Sep 13, 2022 - 04:48 UTC
Investigating
You may encounter delay in withdrawal status update in your wallet but funds might have arrived at your bank accounts. Withdrawal requests that affected includes requests that made between 7th September 3.45pm to 8th September 10am.

We have raised this to the bank to investigate further. We will update as soon as this is resolved.

Withdrawal requests that were made from 8th Sept 10am onwards are processed as usual.

Thank you.
Posted Sep 09, 2022 - 03:38 UTC