Following checks, we can confirm the issue is resolved
Posted Nov 19, 2025 - 08:37 UTC
Monitoring
The service provider has informed us that the issue seems to be resolved. Luno teams are currently conducting checks on our services to confirm and ensure stability.
Posted Nov 18, 2025 - 14:57 UTC
Update
Luno Services continue to be impacted.
Luno teams are continuing to monitor the situation as a priority. We appreciate your patience in this matter.
Posted Nov 18, 2025 - 14:06 UTC
Update
Luno Services continue to be impacted.
Luno teams are continuing to monitor the situation as a priority. We appreciate your patience in this matter.
Posted Nov 18, 2025 - 13:19 UTC
Identified
The downstream service provider is advising that some services are recovering. Some Luno services may still experience delays and Luno teams continue to monitor
Posted Nov 18, 2025 - 12:45 UTC
Investigating
A downstream service provider global outage is causing issues with some Luno services.
Currently we can confirm that you may see a delays in the following services; - KYC Verification - Deposits & Withdrawals across various tokens - ADA (Cardano) staking rewards delays
We are in contact with the service provider to gather latest updates. Luno teams are monitoring the impact closely and any further services that we find to be impacted will be communicated here.
We apologise for the inconvenience and appreciate your patience.