FNB Business Customers Unable To Initiate Deposits In South Africa

Incident Report for Luno

Resolved

Issue has been resolved, thank you for your patience.
Posted Apr 20, 2026 - 08:22 UTC

Identified

We have identified an issue where our FNB Business Account Holders are unable to initiate Deposits into our Account.

We are working with FNB as a high priority to resolve the issue and apologies for any inconvenience caused.
Posted Apr 15, 2026 - 06:29 UTC