Public Holiday Reminder - Withdrawal Requests will take longer than usual in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted May 30, 2024 - 08:01 UTC
Identified
Please note that 29.05.2024 is a public holiday in South Africa. This means any withdrawals from Luno that we send to the Banks won’t be processed until 30.05.2024

Please note that this only applies to ZAR withdrawals. Crypto withdrawals will be processed as normal according to our service level agreements.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted May 28, 2024 - 15:04 UTC