Sign up flow error in Malaysia
Incident Report for
Luno
Resolved
This issue has been resolved.
Thank you for your patience in this matter.
Posted
Oct
02
,
2024
-
14:06
UTC
Update
Update:
We are continuing our investigation on the error that may affect some customers who attempt to sign up for a Luno account.
We will provide updates when they are available
Posted
Sep
27
,
2024
-
12:41
UTC
Identified
We are investigating an issue that may be causing certain customers to receive an error when signing up for a new Luno account.
Our team is working on identifying the error as this is a priority.
Updates to follow.
Posted
Sep
27
,
2024
-
10:05
UTC
×
Subscribe to Incident
Subscribe to updates for
Sign up flow error in Malaysia
via . You'll receive .