Delayed bank withdrawal in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted May 17, 2021 - 02:50 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 17, 2021 - 02:49 UTC
Identified
Withdrawals in Malaysia will not be processed on 13th and 14th May due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 17th May.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted May 11, 2021 - 02:55 UTC