Slow deposits in Nigeria
Incident Report for Luno
Resolved
Redeeming deposit vouchers has returned to normal.

We do apologise for the inconvenience.
Posted Dec 18, 2021 - 03:40 UTC
Identified
Some customers may experience delays in making deposits via vouchers in Nigeria, we hope to see this resolved as soon as possible. If you aren't able to redeem a deposit please try again in a few hours. We'll update this status page as soon as we have an update.

Sincerely sorry about any inconvenience caused.
Posted Dec 17, 2021 - 21:13 UTC