Delayed refunds in Nigeria

Incident Report for Luno

Resolved

This incident has been resolved.
Posted May 12, 2025 - 13:36 UTC

Identified

There is slow responses affecting refunds for Nigerian Customers
Posted May 11, 2025 - 08:29 UTC