Delayed Crypto Withdrawals

Incident Report for Luno

Resolved

We have resolved the issue and are no longer seeing any delays in Crypto Withdrawals.
Thank you for your patience.
Posted Oct 22, 2025 - 08:02 UTC

Monitoring

We have implemented a fix and issue is resolved. We are monitoring for any additional errors.
Posted Oct 21, 2025 - 12:03 UTC

Identified

We have identified an issue were customers are facing delayed crypto withdrawals like BTC, ETH, LTC, BCH, XRP and ERC20 tokens. We are working on the issue as a priority.
Posted Oct 21, 2025 - 10:04 UTC